Fluval Ultra Bright LED light bar: fixable?

Discussion in 'DIY' started by Aquaphobia, Dec 17, 2017.

  1. Aquaphobia

    Aquaphobia Active Member

    Joined:
    Dec 14, 2017
    Messages:
    88
    Likes Received:
    218
    A year or so ago a local pet chain went under and lots of stuff was on sale. Sadly I didn't have much money at the time otherwise I could have got some gorgeous Fluval setups for cheap. But anyway, I opted to buy this Fluval light because a) it was cheap, and b) I got it even cheaper because it has an issue. It was the last one and being a fan of Big Clive on YouTube I thought I had an udea of what the problem was. Then I moved and nothing got done. I really really want to get this thing working though!

    This is the light: http://www.fluvalaquatics.com/ca/product/13572-ultra-bright-led-strip-light/#.WjasLJ9yjqA

    Symptoms: when turned on the lights pulse. I suspect, based on my minimal YouTube "education", that this could have something to do with the capacitors.

    Questions: is it worth fixing and should I try to do it myself or should I leave it to a professional?
     
    #1 Aquaphobia, Dec 17, 2017
    Last edited: Dec 17, 2017
    NightShade, discusbreeder and Mbkemp like this.
  2. Aquaphobia

    Aquaphobia Active Member

    Joined:
    Dec 14, 2017
    Messages:
    88
    Likes Received:
    218
    Heh. It was totally fixable;)

    I figured that the easiest thing to check would be the power supply. If the problem was with a capacitor as I suspected then it would be inside that but not having the proper tools or skills made it a slightly daunting prospect! Solution? Find a working power supply and see if the lights worked. And they do!

    Now I'm just off to double check my understanding of the numbers on the backs of power supplies and make sure I'm not headed for a fire or something :p
     
    toolman, GreenGo and jmaldo like this.
  3. jmaldo

    jmaldo Well-Known Member

    Joined:
    Dec 19, 2017
    Messages:
    170
    Likes Received:
    592
    Good for you. I also had a led malfunction. Yep swapped out the power supply worked fine. Good Luck
     
    toolman and Aquaphobia like this.
  4. Aquaphobia

    Aquaphobia Active Member

    Joined:
    Dec 14, 2017
    Messages:
    88
    Likes Received:
    218

Share This Page

Fishkeepers Lounge

    1. There are currently no users chatting.

    You don't have the necessary permissions to use the chat.

    Web Analytics